1. We have implemented the ability to gift someone a Supporting Membership now! When you access the Upgrade page there is now a 'Gift' button. Once you click that you can enter a username to gift an account Upgrade to. Great way to help support this forum plus give some kudos to anyone who has helped you.
    Fechar Aviso

PID Rex C100

Discussão em 'Equipamentos, Técnicas e Processos' iniciado por lh-correa, 16/4/14.

Ajude o Home Brew Talk Brasil:

  1. 16/4/14 #1

    lh-correa

    lh-correa

    lh-correa

    Well-Known Member

    Afiliado:
    13/6/13
    Mensagens:
    107
    Curtidas Recebidas:
    19
    Pessoal essa semana chegou meu PID Rex C100 que encomendei pelo Aliexpress, bem como o relé ssr e a resistência.

    Vi que tem muita gente aqui no fórum que utiliza esse PID em seu equipamento, então acho interessante fazer um tópico para fins de centralizar as informações e facilitar a retirada de dúvidas do pessoal.

    O manual do PID até menciona as configurações dele, mas de forma muito breve, sem uma explanação detalhada sobre para que cada coisa serve. Não consegui nem achar na internet alguma explicação.

    Então, por enquanto, gostaria de saber se o pessoal do fórum poderia ajudar explicando algumas funções básicas de configuração do PID, do tipo "o que a gente precisa configurar para fazer o troço funcionar direito, sem o risco de estragar alguma coisa", rs!


    Update 16/04/2014:

    segue esquema de ligação do C100, já testado por outro usuário aqui do forum:
    [​IMG]


    Update 17/04/2014:

    Abraço!
     
    dryfon curtiu isso.
  2. 16/4/14 #2

    dryfon

    dryfon

    dryfon

    Well-Known Member

    Afiliado:
    29/10/13
    Mensagens:
    192
    Curtidas Recebidas:
    44
    Muito legal o tópico! Vou ficar de olho nele pois pretendo montar uma panela com aquecimento elétrico e gostaria de usar um controlador PID pra ter maior precisão no controle de temperatura.

    Esse controlador permite que se crie rampas e patamares de temperatura, por exemplo, programar pra que fique durante 50 minutos a 64 graus e depois vá para 75 graus, ou pelo menos determinar quanto tempo deve ficar em uma temperatura?

    Muito obrigado!
    Abraços!
     
  3. 16/4/14 #3

    Frkleal

    Frkleal

    Frkleal

    Well-Known Member

    Afiliado:
    20/11/13
    Mensagens:
    438
    Curtidas Recebidas:
    73
    Eu usei o segundo esquema no meu e funcionou perfeitamente.

    Tentei o primeiro e não consegui fazer funcionar...
     
  4. 17/4/14 #4

    lh-correa

    lh-correa

    lh-correa

    Well-Known Member

    Afiliado:
    13/6/13
    Mensagens:
    107
    Curtidas Recebidas:
    19
    Cara, se não me engano não dá. Mas mesmo assim, não é grande problema, pq basta setar a nova temperatura quando for necessário fazer a rampa, o que é bem simples, pelo que já andei vendo.

    Blz, valeu a contribuição! Já tirei o primeiro esquema do tópico pra não confundir ninguém.

    --


    Outra coisa, alguém já usou o C100 ligado em geladeira pra controle de fermentação?
    Li que isso é complicado pq o relé envia pequenos e rápidos pulsos (acho que é isso), o que poderia queimar o compressor da geladeira/freezer.
    Contudo, acho que tem como configurar o PID para que não haja esses pulsos quando se aproxima da temperatura.

    Ainda, parece que há uma forma de fazer ele funcionar sem ser no SSR, pois o C100 tem um outro relé interno para ligar um alarme, mas que pode ser utilizado para ligar uma lâmpada ou a própria geladeira.

    Achei um manual que descreve as funções um pouco mais detalhadamente:
    http://www.fmfranklin.com.au/products/data/rkc/c100set.pdf
     
    Pellin curtiu isso.
  5. 17/4/14 #5

    fabianoccc

    fabianoccc

    fabianoccc

    Well-Known Member

    Afiliado:
    11/6/13
    Mensagens:
    92
    Curtidas Recebidas:
    28
    Mais um acompanhando o tópico. Meu rex c-100 já chegou. Agora só falta a resistência.
     
  6. 17/4/14 #6

    Pellin

    Pellin

    Pellin

    Well-Known Member

    Afiliado:
    6/9/13
    Mensagens:
    189
    Curtidas Recebidas:
    32
    Olá amigos,

    Este esquema foi eu quem postou, apenas para atualizar, instalei um interruptor no fio 4 (positivo) do rele. assim posso ligar e desligar a resistencia não só quando o controlador determina, mas tbm quando me é conveniente. Fica bem seguro.

    Abraço
    Pellin
     
    lh-correa curtiu isso.
  7. 25/4/14 #7

    vbrunetti

    vbrunetti

    vbrunetti

    Active Member

    Afiliado:
    25/4/14
    Mensagens:
    40
    Curtidas Recebidas:
    1
    Alguem tem algum material de como configurar esse pid ? nao estou entendendo o material em ingles.
     
  8. 15/8/14 #8

    vbrunetti

    vbrunetti

    vbrunetti

    Active Member

    Afiliado:
    25/4/14
    Mensagens:
    40
    Curtidas Recebidas:
    1
    A imagem do esquema de ligação sumiu ... alguem poderia mandar o esquema de ligação de novo ??? abraços
     
  9. 29/8/14 #9

    TiaoUngaro

    TiaoUngaro

    TiaoUngaro

    Member

    Afiliado:
    16/4/14
    Mensagens:
    11
    Curtidas Recebidas:
    3
    Comprei os Rex, SSRs, resistências e montei tudo de forma provisória para teste. Precisei reconfigurar o Rex para PT100 e aplicar uma correção de +2ºC. Até aí tudo certo.
    No teste, após atingir a temperatura desejada, o SSR continua a enviar pulsos de tensão e com isso a temperatura não deixa de subir e, embora lentamente, atinge valores muito acima do desejado.

    Perguntas :
    1 . Esse desvio de 2ºC é aceitável num pT100 ?
    2. Qual parâmetro pode estar configurado errado e causando essa temperatura exagerada?
    3. Quando altera o SV ou desliga o Rex os valores estabelecidos pelo Auto Tunning são cancelados. Tem como bloquear estes valores e mantê-los ativos?

    Obrigado a todos e meu "valeu !" antecipado a quem puder ajudar.

    Abraços
     
  10. 29/8/14 #10

    lh-correa

    lh-correa

    lh-correa

    Well-Known Member

    Afiliado:
    13/6/13
    Mensagens:
    107
    Curtidas Recebidas:
    19
    Achei no forum o esquema de ligação que o pessoal comenta que funciona.
    [​IMG]


    1 e 2. Com relação ao desvio de 2ºC, não sei o que pode ser, talvez problema no sensor?

    3. Acho que o autotunig desativa sempre que o aparelho é desligado. Aquela luz da função AT apaga automaticamente sempre que ele termina de configurar o autotuning.

    Traduzi (meia boca, ahuha) uma parte do manual que fala do AT, já dá uma luz sobre a função:

    O autotuning (AT) mede automaticamente, calcula e define as constantes PID e as constantes LBA (Loop Break Alarm).

    As seguintes condições são necessárias para realizar o autotuning:

    Cuidado para usar o autotuning (AT):
    Quando uma mudança de temperatura (para cima e/ou para baixo) é de 1ºC ou menos por minuto durante o autotuning, o autotuning pode ser cancelado antes de calcular os valores de PID. Nesse caso, ajustar os valores de PID manualmente.

    Isso pode ocorrer quando o valor definido é próximo da temperatura ambiente ou é próximo da temperatura máxima atingida pela carga.

    * Requisitos para o início do AT:
    Inicie o autotuning, somente quando estiveram presentes todas as seguintes condições:
    - Antes de iniciar a função AT, desative todos os outros ajustes de parâmetros, exceto o PID e LBA .
    - Certifique que a função LCK não esteja ativada.

    Quando o autotuning estiver concluído, o controlador volta automaticamente para a função de controle PID.

    * Requisitos para o cancelamento do AT:
    O autotuning é cancelado se qualquer uma das seguintes condições ocorrerem:
    - Quando o valor ajustado (SV) é alterado.
    - Quando o valor "bias" PV (valor medido) é alterado.
    - Quando o PV se torna anormal devido ao "burnout".
    - Quando a energia é desligada (ou seja, desligamento do aparelho).
    - Quando ocorre queda de energia maior do que 20 ms.

    Se o AT é cancelado, o controlador muda imediatamente para o controle PID. Os valores de PID serão os mesmos de antes da ativação do AT.

    Quando o AT é concluído, o controlador muda imediatamente para o controle PID. Se o sistema de controle não permite completar o ciclo do AT, definir cada constante PID manualmente para atender as necessidades da aplicação.

    Glossário
    AT - autotuning
    SV - set value (temperatura setada)
    PV - measured value (temperatura medida)
    LBA - Loop break alarm
     
    stormridersp curtiu isso.
  11. 29/8/14 #11

    izumita

    izumita

    izumita

    New Member

    Afiliado:
    29/8/14
    Mensagens:
    1
    Curtidas Recebidas:
    0
    Gente eu comprei o rex c100 e o rele ssr, liguei os fios conforme a imagem, porem acho que estou errando algo no PID pois quando aumento a temperatura o rele ssr não aciona, não é problema no rele pois testei com um carregador de celular e a luz liga, e testei com multimetro na saida 4 e 5 não sai corrente nenhuma e a luz out do controlador acesa. Alguem sabe como resolver ?
     
  12. 1/9/14 #12

    TiaoUngaro

    TiaoUngaro

    TiaoUngaro

    Member

    Afiliado:
    16/4/14
    Mensagens:
    11
    Curtidas Recebidas:
    3
    Luis Henrique,

    Legal, obrigado pelo seu empenho !

    Em cada manual que pego (e temos vários) percebo que ignora alguma parte da configuração.
    Então, imprimi 3 deles e juntei tudo.
    Chequei TODOS os parâmetros do Rex, comparando-os com os que o fabricante teoricamente adota como padrão. Encontrei 2 que tinham os valores diferentes
    "P" e SLL5; corrigi, fiz outro teste e ficou tudo certo.

    Como tem muita gente investindo nessa pequena automação, seria legal se desenvolvêssemos um manual nosso, simplificado, com todos os valores a serem adotados para se iniciar o uso. Depois, o caboclo cervejeiro vai conhecendo melhor e ajustando do seu jeito.

    Antes de receber os aparelhos, lembro de ter visto um post, que não encontrei de novo, onde o cara apresentava sua sugestão de configuração. Vou continuar procurando para poder comparar com a minha e aprender mais um pouco.

    Forte Abraço

    Tião
     
  13. 1/9/14 #13

    lh-correa

    lh-correa

    lh-correa

    Well-Known Member

    Afiliado:
    13/6/13
    Mensagens:
    107
    Curtidas Recebidas:
    19
    Tião, peguei alguns manuais e, realmente, notei que existem várias versões, com diferenças entre eles.

    No post inaugural do tópico, coloquei um link com um manual que achei bem interessante e me parece mais completo e explicativo.

    Talvez sirva para tomarmos de base para fazermos esse manual nosso, simplificado.

    Segue o link:
    http://www.rkcinst.co.jp/english/pdf_manual/imnzc22e1.pdf

    Abraço!
     
  14. 12/12/14 #14

    eduatletico

    eduatletico

    eduatletico

    Well-Known Member

    Afiliado:
    30/10/13
    Mensagens:
    89
    Curtidas Recebidas:
    6
    Luis, como está o uso do do Rex ?
    Pergunto, pois ontem a noite fui tentar calibrar os dois Rex q comprei. Deixei ferver a água com um termômetro analógico pra verificar a temperatura. Os dois Rex davam diferença na leitura. Aí corrigi pelo último parâmetro da config. Ficaram os dois corretos. MAS, qdo deixo em temperatura ambiente, eles ficam com uma diferença de 8 graus! Será q esse autotune me ajudaria? Rsrs.. To quase jogando fora esses rex.. Abraço!
     
  15. 12/12/14 #15

    lh-correa

    lh-correa

    lh-correa

    Well-Known Member

    Afiliado:
    13/6/13
    Mensagens:
    107
    Curtidas Recebidas:
    19
    Edu, talvez o autotune te ajude. Mais acima tem uma parte traduzida do manual sobre a função. Verifique também se equipamento tá configurado corretamente para o tipo de sensor que tu estás utilizando.
     
  16. 12/12/14 #16

    eduatletico

    eduatletico

    eduatletico

    Well-Known Member

    Afiliado:
    30/10/13
    Mensagens:
    89
    Curtidas Recebidas:
    6
    Então... Ta configurado sim. Coloquei um PT 100. Tá com variação de 0.1° C. Vou tentar o autotune mesmo. Valeu! =D
     
  17. 13/12/14 #17

    TiaoUngaro

    TiaoUngaro

    TiaoUngaro

    Member

    Afiliado:
    16/4/14
    Mensagens:
    11
    Curtidas Recebidas:
    3
    Edu, calma.
    Sofri um bocado pra colocar os meus pra funcionar também.
    Olha, o autotune não ajda nisso não! O auto ajusta apenas as variáveis envolvidas no controle (P, I e D).
    Tenho algumas sugestões:
    1) já inverteu os sensores para saber de onde vem a diferença ?
    2) quando vc liga o controlador aparece o PT que indica que está ajustado para pt100? Digo isso pq um dos meus já veio configurado para pt100, o outro não.
    Precisei alterar a variável SL1 na segunda etapa de ajustes.
    3) Vc deve ter corrigido a medição pelo Sc ou Pb, certo ? Na operação, cheque o valor de dF, na terceira etapa de ajustes.
    4) se nada der certo, passe o número do modelo dos seus, vou comparar com os meus e aí, se forem iguais, fazemos uma checagem parâmetro a parâmetro.

    abraço

    tião ameba
     
  18. 14/12/14 #18

    eduatletico

    eduatletico

    eduatletico

    Well-Known Member

    Afiliado:
    30/10/13
    Mensagens:
    89
    Curtidas Recebidas:
    6
  19. 8/1/15 #19

    lh-correa

    lh-correa

    lh-correa

    Well-Known Member

    Afiliado:
    13/6/13
    Mensagens:
    107
    Curtidas Recebidas:
    19
    @eduatletico, a respeito do uso do meu PID ainda estou testando, pois ainda não tenho a resistência para montar a panela (comprei da china agora), estou montando o equipamento beem aos poucos, conforme a grana permite, hehe

    Mas já venho testando ele, estudando as funções. Tentando calibrar a temperatura, encontrei um problema semelhante ao que tu relatou: em temperatura ambiente ele se equipara à temperatura do termômetro analógico (aqueles incoterm, que as lojas de insumos vendem), mas subindo a temperatura acima de 70ºC chega a dar uma diferença de 10 graus (para mais, no REX).

    Não sei o que pode ser, vou comprar um sensor novo para ver se resolve (preciso de um novo igual, pois o que tenho o tamanho da rosca não encaixa nas minhas conexões). Configurar a função SC não me adianta, pois conforme a temperatura baixa, a discrepância se inverte. Estou utilizando Termopar tipo K.

    Será que esses incoterm são confiáveis para a calibragem? Vou ter que conseguir outro para calibrar?
     
  20. 8/1/15 #20

    eduatletico

    eduatletico

    eduatletico

    Well-Known Member

    Afiliado:
    30/10/13
    Mensagens:
    89
    Curtidas Recebidas:
    6
    Fala Luiz!

    Então.. eu estava medindo com um daqueles analógicos de inox (já calibrado). Estou usando PT100 nos dois REX. Não tentei ainda usar os sensores K pra ver se essa diferença se mantém.
     

Compartilhe esta Página