• We have implemented the ability to gift someone a Supporting Membership now! When you access the Upgrade page there is now a 'Gift' button. Once you click that you can enter a username to gift an account Upgrade to. Great way to help support this forum plus give some kudos to anyone who has helped you.

Geladeira Cervejeira / Kegerator - Baixo Custo com Aplicativo no Celular

Ajude o Home Brew Talk Brasil:

Luiz Artur

Member
Afiliado
8/4/20
Mensagens
18
Localização
Rio de Janeiro
Camaradas fiz alguns updates no sistema.

- Adicionado Display
- Integrado ao iSpindel
- Integrado ao BrewFather
- Possibilidade de selecionar o sensor que controlará o aquecimento/resfriamento
- Sensor do iSpindel pode ser usado para controlar o aquecimento/resfriamento e sensor com fio fica sendo backup no caso do iSpindel ficar sem bateria.
- Previsão de ABV % no APP



Ver anexo 123938
Parabéns Helton, cada dia melhor. Se não se importar, poderia compartilhar conosco os códigos fontes? Valeu e um forte abraço.
 

Fernando Pedro

Active Member
Afiliado
9/12/19
Mensagens
29
Localização
São Paulo
Olá Helton, tudo bem?
Preciso de uma ajuda sua, eu cmprei todos os componentes, e ontem consegui gravar o arquivo Geladeira_V4.bin na memória da ESP, e logo após consegui conectar no ESP pela rede IoTBrew no WiFi, e fiz todas as configurações conforme o vídeo, porém hoje quando fui dar continuidade nas tarefas, não consegui mais encontrar a rede IoTBrew no WiFi do celular, percebi que o led da placa, depois que ligo na energia elétrica, fica piscando, e não mantem acesa como no seu vídeo, será que eu danifiquei a placa? Inclusive eu já regravei o Geladeira_V4.bin mais de uma vez, e nada mudou. Poderia me dar uma dica, por favor?
Obrigado e Abs.
 

Helton Fagner

Well-Known Member
Afiliado
24/10/19
Mensagens
355
Localização
São Paulo
Olá Helton, tudo bem?
Preciso de uma ajuda sua, eu cmprei todos os componentes, e ontem consegui gravar o arquivo Geladeira_V4.bin na memória da ESP, e logo após consegui conectar no ESP pela rede IoTBrew no WiFi, e fiz todas as configurações conforme o vídeo, porém hoje quando fui dar continuidade nas tarefas, não consegui mais encontrar a rede IoTBrew no WiFi do celular, percebi que o led da placa, depois que ligo na energia elétrica, fica piscando, e não mantem acesa como no seu vídeo, será que eu danifiquei a placa? Inclusive eu já regravei o Geladeira_V4.bin mais de uma vez, e nada mudou. Poderia me dar uma dica, por favor?
Obrigado e Abs.
Fala amigo, a rede IoTBrew fica ativa somente para você fazer as configurações, uma vez configurado no seu Wifi ele não aparece mais. Segure o botão FLASH do ESP por 10 segundos para resetar as configurações e ela aparecerá novamente. Quando acessar a pagina de configuração pelo ip 192.168.4.1 já entre com os dados do seu Wifi e tbm o token do Blynk, assim vc já terá o controle pelo aplicativo.
 

Fernando Pedro

Active Member
Afiliado
9/12/19
Mensagens
29
Localização
São Paulo
Fala amigo, a rede IoTBrew fica ativa somente para você fazer as configurações, uma vez configurado no seu Wifi ele não aparece mais. Segure o botão FLASH do ESP por 10 segundos para resetar as configurações e ela aparecerá novamente. Quando acessar a pagina de configuração pelo ip 192.168.4.1 já entre com os dados do seu Wifi e tbm o token do Blynk, assim vc já terá o controle pelo aplicativo.
Olá Helton, obrigado pela explicação...
Então pelo que eu entendi, depois de configurado não será mais necessário conectar na IoTBrew, ok.
Aí tenho outras dúvidas:
1. O LED não tem que ficar aceso sempre?
2. No aplicativo, é normal ficar aparecendo a mensagem "...connected" e "...disconnectaded"?
3. O aplicativo não lê a temperatura do sensor, o que pode ser?
Dá uma olhada na imagens...
Obrigado.
 

Attachments

Helton Fagner

Well-Known Member
Afiliado
24/10/19
Mensagens
355
Localização
São Paulo
Olá Helton, obrigado pela explicação...
Então pelo que eu entendi, depois de configurado não será mais necessário conectar na IoTBrew, ok.
Aí tenho outras dúvidas:
1. O LED não tem que ficar aceso sempre?
2. No aplicativo, é normal ficar aparecendo a mensagem "...connected" e "...disconnectaded"?
3. O aplicativo não lê a temperatura do sensor, o que pode ser?
Dá uma olhada na imagens...
Obrigado.
Exatamente, depois de configurado não precisa mais conectar a rede IoTBrew.

1. O LED deve ficar aceso fixo, isso indica que está conectado aos servidores do Blynk
2. Não é normal ele ficar alternando. Isso está acontecendo porque ele não está detectando seu sensor de temperatura. O sistema reincia automaticamente quando nenhum sensor não é detectado. Esse reinicio é o motivo dele estar conectando e desconectando toda hora no Blynk.
3. Verifica as conexões do sensor. Amarelo no D6, vermelho no 3.3V e preto no GND. Resistor de 4k7 entre o amarelo e o vermelho (D6 e 3.3V). De preferência solde os cabos do sensor e o resistor. Com o manuseio do cabo pode dar problema de contato.
 

Helton Fagner

Well-Known Member
Afiliado
24/10/19
Mensagens
355
Localização
São Paulo
Olá Helton, obrigado pela explicação...
Então pelo que eu entendi, depois de configurado não será mais necessário conectar na IoTBrew, ok.
Aí tenho outras dúvidas:
1. O LED não tem que ficar aceso sempre?
2. No aplicativo, é normal ficar aparecendo a mensagem "...connected" e "...disconnectaded"?
3. O aplicativo não lê a temperatura do sensor, o que pode ser?
Dá uma olhada na imagens...
Obrigado.
Acabei de observar nas imagens que vc enviou que vc está usando a versão antiga do app no Blynk. Apague o projeto no Blynk e use o QR do link abaixo para atualizar.

Link para baixar o QR do aplicativo na versão mais simples:

Após a importação do novo projeto para o Blynk será gerado um novo token, repita o processo descrito anteriormente para recadastrar o token.
 

Helton Fagner

Well-Known Member
Afiliado
24/10/19
Mensagens
355
Localização
São Paulo
Parabéns Helton, cada dia melhor. Se não se importar, poderia compartilhar conosco os códigos fontes? Valeu e um forte abraço.
Bom dia Luiz, td certo amigo? Só preciso me organizar aqui para colocar no github. Estou com outros projetos em andamento que estão me consumindo. Assim que estiver no ar dou um toque aqui no forum. Abraço.
 

Tiago Einsfeld

Active Member
Afiliado
26/9/18
Mensagens
39
Localização
Sapiranga - RS
beleza Helton ...
montei meu sistema, mas aparece como se o esp estivesse desconectado, comprei até a versão mais completa pra ver se aparecia a leitura da temperatura, mas não aparece nada. No display aparece a temperatura certinho, mas no blynk não. segue em anexo fotos. aparece a mensagem 'wasn't online yet".... como se não estivesse conectdo. O meu esp é com chip cp 210. E a forma de configuração de rede no iotbrew, é um pouco diferente também ...
 

Attachments

Helton Fagner

Well-Known Member
Afiliado
24/10/19
Mensagens
355
Localização
São Paulo
beleza Helton ...
montei meu sistema, mas aparece como se o esp estivesse desconectado, comprei até a versão mais completa pra ver se aparecia a leitura da temperatura, mas não aparece nada. No display aparece a temperatura certinho, mas no blynk não. segue em anexo fotos. aparece a mensagem 'wasn't online yet".... como se não estivesse conectdo. O meu esp é com chip cp 210. E a forma de configuração de rede no iotbrew, é um pouco diferente também ...
Amigo ao que tudo indica o Token do Blynk não foi salvo. Não se esqueça que depois que vc clica em "SAVE" ele aparece na tela a informação para aguardar 10 segundos.. Como abaixo

Trying to connect ESP to the INTELBRAS SALA network.
Give it 10 seconds or so and check how it went.
The IoTBrew network you are connected to will be restarted on the radio channel of the INTELBRAS SALA network. You may have to manually reconnect to the IoTBrew network.

Vc então clica em "how it went" ele volta a tela inicial e vc deve clicar em "EXIT PORTAL"
Se não clicar em "EXIT PORTAL" ele não grava o token, e consequentemente quando reinicia não consegue conectar ao servidor do Blynk.
 

Tiago Einsfeld

Active Member
Afiliado
26/9/18
Mensagens
39
Localização
Sapiranga - RS
Amigo ao que tudo indica o Token do Blynk não foi salvo. Não se esqueça que depois que vc clica em "SAVE" ele aparece na tela a informação para aguardar 10 segundos.. Como abaixo

Trying to connect ESP to the INTELBRAS SALA network.
Give it 10 seconds or so and check how it went.
The IoTBrew network you are connected to will be restarted on the radio channel of the INTELBRAS SALA network. You may have to manually reconnect to the IoTBrew network.

Vc então clica em "how it went" ele volta a tela inicial e vc deve clicar em "EXIT PORTAL"
Se não clicar em "EXIT PORTAL" ele não grava o token, e consequentemente quando reinicia não consegue conectar ao servidor do Blynk.
agora deu certo .....obrigado .... mais uma coisa ...eu coloquei a temp alvo para 17 graus , e dai coloquei o sensor num copo com agua e chegou a 15 graus e ainda não ligou o aquecedor ... dai eu coloquei em off e depois voltei pro on e dai ligou o aquecer .... a histerese está em 0.3 .... isso aconteceu também com o resfriar, tem que colocor em off e depois em on e dai começa a resfriar .... poucas vezes ele acionou sozinho o aquecer e o resfriar
 

Helton Fagner

Well-Known Member
Afiliado
24/10/19
Mensagens
355
Localização
São Paulo
agora deu certo .....obrigado .... mais uma coisa ...eu coloquei a temp alvo para 17 graus , e dai coloquei o sensor num copo com agua e chegou a 15 graus e ainda não ligou o aquecedor ... dai eu coloquei em off e depois voltei pro on e dai ligou o aquecer .... a histerese está em 0.3 .... isso aconteceu também com o resfriar, tem que colocor em off e depois em on e dai começa a resfriar .... poucas vezes ele acionou sozinho o aquecer e o resfriar
Quando há inversão de temperatura, por exemplo se ele estava esfriando e passou a histerese desligou, não começa imediatamente a aquecer (ou vice-versa) isso devido a inércia termica. A inversão do frio para o quente ou do quente para o frio só se dá depois de 6 horas. Do contrário haveria consumo demasiado de energia devido as inversões. Vc pode interferir nesse processo, fazendo ele inverter imediatamente o processo desligando e ligando o sistema, como vc fez. Estou estudando adicionar no setup uma opção onde você define o tempo de espera para inversão, porém, de todos os testes que fiz 6 horas parece ser um bom tempo.

Estou adicionando um icone no display para infomar quando o Blynk está conectado. Em mais alguns minutos coloco o link do firmware aki, juntamente com os passos para atualizar.
 

Tiago Einsfeld

Active Member
Afiliado
26/9/18
Mensagens
39
Localização
Sapiranga - RS
Quando há inversão de temperatura, por exemplo se ele estava esfriando e passou a histerese desligou, não começa imediatamente a aquecer (ou vice-versa) isso devido a inércia termica. A inversão do frio para o quente ou do quente para o frio só se dá depois de 6 horas. Do contrário haveria consumo demasiado de energia devido as inversões. Vc pode interferir nesse processo, fazendo ele inverter imediatamente o processo desligando e ligando o sistema, como vc fez. Estou estudando adicionar no setup uma opção onde você define o tempo de espera para inversão, porém, de todos os testes que fiz 6 horas parece ser um bom tempo.

Estou adicionando um icone no display para infomar quando o Blynk está conectado. Em mais alguns minutos coloco o link do firmware aki, juntamente com os passos para atualizar.
 

Tiago Einsfeld

Active Member
Afiliado
26/9/18
Mensagens
39
Localização
Sapiranga - RS
Entendi... Então pra mim não vai funcionar, pois aqui no sul a noite quando liga minha geladeira por exemplo se setei para 18 graus, quando chegar nos 18 desliga mas a temperatura ainda baixa até uns 16 se não tivesse o aquecimento imediato, é muita variação... Preciso desse procedimento no inverno... E com o stc1000 que tenho ligado na geladeira e na lâmpada, a variação máxima é de 0,6 graus.... Que pena estava muito empolgado com esse sistema para controlar a distância..
 

Helton Fagner

Well-Known Member
Afiliado
24/10/19
Mensagens
355
Localização
São Paulo
Segue update com alteração dos ícones e adição do ícone do Blynk indicando conexão com o servidor do App. Se o seu Blynk não estiver conectando veja se o "B" aparece no display, se estiver você está no App errado, se o ícone não aparecer refaça o processo mencionado nos posts anteriores e confirme o token do Blynk.

hot.jpegcold.jpeg

Se você já configurou seu dispositivo no Wifi, basta acessar o dispositivo através do IP seguido da porta 8080 na seguinte sintaxe:

ip:8080/update
(troque "ip" acima pelo número configurado no seu dispositivo.)

Exemplo:

192.168.0.40:8080/update

update.PNG

Baixe a atualização através do link abaixo, selecione "Escolher arquivo", busque o arquivo que você baixou e clique em "Update".

Link: https://drive.google.com/file/d/1ZQAlPswFwsLHFNly5-ZlxcCyCCzWh479/view?usp=sharing

Uma vez atualizado se os dados de configuração estiverem okay, não haverá necessidade de reconfigurar. Caso precise revisar alguma informação aperte o botão flash por 10 segundos e siga o processo de configuração.
 

Helton Fagner

Well-Known Member
Afiliado
24/10/19
Mensagens
355
Localização
São Paulo
Entendi... Então pra mim não vai funcionar, pois aqui no sul a noite quando liga minha geladeira por exemplo se setei para 18 graus, quando chegar nos 18 desliga mas a temperatura ainda baixa até uns 16 se não tivesse o aquecimento imediato, é muita variação... Preciso desse procedimento no inverno... E com o stc1000 que tenho ligado na geladeira e na lâmpada, a variação máxima é de 0,6 graus.... Que pena estava muito empolgado com esse sistema para controlar a distância..
Amigo vale a pena testar, nesse sistema a histerese não é o único parametro de analise, quando percebe uma queda brusca ou uma elavação brusca na temperatura ele desliga/liga o resfriamento/aquecimento.
 

Tiago Einsfeld

Active Member
Afiliado
26/9/18
Mensagens
39
Localização
Sapiranga - RS
esse parâmetro para fazer a troca do ciclo (resfriar/aquecer) de 6 em 6 horas, pode ser alterado em alguma programação, ou é fixo ?
 

Helton Fagner

Well-Known Member
Afiliado
24/10/19
Mensagens
355
Localização
São Paulo
Última edição:

Fernando Pedro

Active Member
Afiliado
9/12/19
Mensagens
29
Localização
São Paulo
Exatamente, depois de configurado não precisa mais conectar a rede IoTBrew.

1. O LED deve ficar aceso fixo, isso indica que está conectado aos servidores do Blynk
2. Não é normal ele ficar alternando. Isso está acontecendo porque ele não está detectando seu sensor de temperatura. O sistema reincia automaticamente quando nenhum sensor não é detectado. Esse reinicio é o motivo dele estar conectando e desconectando toda hora no Blynk.
3. Verifica as conexões do sensor. Amarelo no D6, vermelho no 3.3V e preto no GND. Resistor de 4k7 entre o amarelo e o vermelho (D6 e 3.3V). De preferência solde os cabos do sensor e o resistor. Com o manuseio do cabo pode dar problema de contato.
Olá Helton,
Obrigado pelas dicas, agora deu certo, estou conseguindo ler a temperatura, só que agora estou tendo outro problema, o display não liga.
Tenho duas dúvidas
1- O display só funciona na versão completa do softare?
2- Ainda não liguei o módulo relê, preciso ligar ele antes de ligar o display?

Mais uma vez, obrigado pelas dicas.
Abs.
 
Topo