• We have implemented the ability to gift someone a Supporting Membership now! When you access the Upgrade page there is now a 'Gift' button. Once you click that you can enter a username to gift an account Upgrade to. Great way to help support this forum plus give some kudos to anyone who has helped you.

CraftbeerPi não inicia

Ajude o Home Brew Talk Brasil:

P.V.R.F

Member
Afiliado
10/2/19
Mensagens
7
Localização
Santa Maria - RS
Boa tarde pessoal, tentei procurar algum tópico aqui mas não encontrei. Eu tinha o CBP 3 instalado e funcionando 100% no meu RaspberryPi. Porem após a queima da minha placa, refiz a instalação do cartão e coloquei em outra Raspberry. Porem eu não estou conseguindo iniciar ele. Já instalei uns 4 raspbian diferentes, tentei instalar o CBP 2.2, o 3.0 e nenhum deles quer saber de iniciar. Já formatei e reinstalei tudo no cartão mais de 20 vezes e não há santo que faça funcionar. Alguém sabe o que pode estar acontecendo ou já teve esse problema? Quando vejo o status do CPB 3 pelo terminal diz que ele está rodando, mas não tem jeito dele abrir no navegador. Se alguém puder me dar uma luz.
Tentei também instalar sem fazer as atualizações utilizando o Jessie e naaadaaa faz funcionar.
Desde Já eu agradeço.
 
Afiliado
30/10/19
Mensagens
13
Localização
Jundiaí
Boa noite, como está tentando acessar via navegador? Está usando a porta 5000 ex: 192.168.0.100:5000? Sugiro espetar um monitor para poder verificar caso haja erros de inicialização você consegue acompanhar pelo boot do rasp na tela do monitor. Aqui quando não quer subir o sistema o monitor me retorna o problema, normalmente resolvo reconectando os cabos.
 

P.V.R.F

Member
Afiliado
10/2/19
Mensagens
7
Localização
Santa Maria - RS
Boa noite, como está tentando acessar via navegador? Está usando a porta 5000 ex: 192.168.0.100:5000? Sugiro espetar um monitor para poder verificar caso haja erros de inicialização você consegue acompanhar pelo boot do rasp na tela do monitor. Aqui quando não quer subir o sistema o monitor me retorna o problema, normalmente resolvo reconectando os cabos.
O sistema operacional está iniciando normalmente. Estou com ele ligado no monitor. O problema é o Craftbeerpi que não está querendo funcionar. Coloco o ip:5000 e da apenas aquela tela de que não tem página (connection refused).
 

longo

Active Member
Afiliado
2/3/18
Mensagens
28
Olha na pasta do craftbeerpi, deve ter alguma pasta de log, abre os arquivos e vc vai ter uma ideia do que está acontecendo
 

P.V.R.F

Member
Afiliado
10/2/19
Mensagens
7
Localização
Santa Maria - RS
Lá na pasta do craftbeerpi em logo tem apenas o arquivo empty (vazio). Mas hoje tentei reinstalar tudo de novo e apáreçeuessas mensagens abaixo em vermelho.

Exception:
Traceback (most recent call last):
File "/usr/lib/python2.7/dist-packages/pip/basecommand.py", line 215, in main
status = self.run(options, args)
File "/usr/lib/python2.7/dist-packages/pip/commands/install.py", line 353, in run
wb.build(autobuilding=True)
File "/usr/lib/python2.7/dist-packages/pip/wheel.py", line 749, in build
self.requirement_set.prepare_files(self.finder)
File "/usr/lib/python2.7/dist-packages/pip/req/req_set.py", line 380, in prepare_files
ignore_dependencies=self.ignore_dependencies))
File "/usr/lib/python2.7/dist-packages/pip/req/req_set.py", line 554, in _prepare_file
require_hashes
File "/usr/lib/python2.7/dist-packages/pip/req/req_install.py", line 278, in populate_link
self.link = finder.find_requirement(self, upgrade)
File "/usr/lib/python2.7/dist-packages/pip/index.py", line 465, in find_requirement
all_candidates = self.find_all_candidates(req.name)
File "/usr/lib/python2.7/dist-packages/pip/index.py", line 423, in find_all_candidates
for page in self._get_pages(url_locations, project_name):
File "/usr/lib/python2.7/dist-packages/pip/index.py", line 568, in _get_pages
page = self._get_page(location)
File "/usr/lib/python2.7/dist-packages/pip/index.py", line 683, in _get_page
return HTMLPage.get_page(link, session=self.session)
File "/usr/lib/python2.7/dist-packages/pip/index.py", line 792, in get_page
"Cache-Control": "max-age=600",
File "/usr/share/python-wheels/requests-2.12.4-py2.py3-none-any.whl/requests/sessions.py", line 501, in get
return self.request('GET', url, **kwargs)
File "/usr/lib/python2.7/dist-packages/pip/download.py", line 386, in request
return super(PipSession, self).request(method, url, *args, **kwargs)
File "/usr/share/python-wheels/requests-2.12.4-py2.py3-none-any.whl/requests/sessions.py", line 488, in request
resp = self.send(prep, **send_kwargs)
File "/usr/share/python-wheels/requests-2.12.4-py2.py3-none-any.whl/requests/sessions.py", line 609, in send
r = adapter.send(request, **kwargs)
File "/usr/share/python-wheels/CacheControl-0.11.7-py2.py3-none-any.whl/cachecontrol/adapter.py", line 47, in send
resp = super(CacheControlAdapter, self).send(request, **kw)
File "/usr/share/python-wheels/requests-2.12.4-py2.py3-none-any.whl/requests/adapters.py", line 423, in send
timeout=timeout
File "/usr/share/python-wheels/urllib3-1.19.1-py2.py3-none-any.whl/urllib3/connectionpool.py", line 643, in urlopen
_stacktrace=sys.exc_info()[2])
File "/usr/share/python-wheels/urllib3-1.19.1-py2.py3-none-any.whl/urllib3/util/retry.py", line 315, in increment
total -= 1
TypeError: unsupported operand type(s) for -=: 'Retry' and 'int'
 

P.V.R.F

Member
Afiliado
10/2/19
Mensagens
7
Localização
Santa Maria - RS
Outras Vezes ele aparece no terminal a mensagem
gitdb2 requires Python '>-3.4' but the running Python is 2.7.13

Já fiz a instalação com o sistema atualizado e sem atualizar.
 

guilosch

Well-Known Member
Afiliado
3/12/15
Mensagens
59
Vai na pasta craftbeerpi3 e executa o run.py (sudo ./run.py). Se tiver algum erro, vai mostrar ali mesmo.
 

Rafael Pierozzi

New Member
Afiliado
24/5/20
Mensagens
4
Localização
Brasil - Jundiaí - SP
Outras Vezes ele aparece no terminal a mensagem
gitdb2 requires Python '>-3.4' but the running Python is 2.7.13

Já fiz a instalação com o sistema atualizado e sem atualizar.
Olá, tive o mesmo problema, e enquanto esse erro do gitdb2 não foi resolvido a instalação não foi pra frente .....
Fiz muitas coisas e lembro exatamente o que resolveu, mas comece por este link:
Avise se sumir essa linha de erro.
att
 

Latest posts

Topo