• We have implemented the ability to gift someone a Supporting Membership now! When you access the Upgrade page there is now a 'Gift' button. Once you click that you can enter a username to gift an account Upgrade to. Great way to help support this forum plus give some kudos to anyone who has helped you.

Controlador Craftbeerpi

Ajude o Home Brew Talk Brasil:

Gu_MAZZA

Well-Known Member
Afiliado
12/3/17
Mensagens
238
Boa tarde,
Onde posso comprar?


Att
Depois de eu testar, vou disponibilizar em meu site.

 

perlporter

Well-Known Member
Afiliado
4/4/16
Mensagens
46
Bom dia amigos!
Estou encontrando uma grande dificuldade na instalação do CBP.
Quando vou executar o CBP mostra erro no módulo GIT e quando tento instalar ele.
Alguém poderia me ajudar? Não sei o que estou fazendo de errado.
Abraços
Ia responder mas já resolvemos kkkk

UPDATE March 2020: Thanks to the commenter Paul Grimes pointing out that the gitdb PyPI package that CBP3 requires was updated early March 2020, and now is only compatible with Python 3.4 or greater. To get gitdb to install, you need to specify the version – added below.

fiz um fork do projeto com uma correção

git clone perlporter/craftbeerpi3
 

Rafael Vitorino

New Member
Afiliado
13/6/18
Mensagens
4
Localização
Belo Horizonte, Minas Gerais
Me desculpe minha ignorância no assunto... na minha configuração estou utilizando GPIO_SIMPLE, acho que é este o nome, pensei em tentar usar o GPIO_PWM mas não sei se iria surtir algum efeito.
Mesmo assim obrigado pela aula :)
Não amigo, para controlar a potência você precisa de uma placa PWM, sem ela vc vai é queimar mais rápido o seu SSR, porque ele vai ficar ligando e desligando em uma frequência muito maior!!!
 

Gu_MAZZA

Well-Known Member
Afiliado
12/3/17
Mensagens
238
Não amigo, para controlar a potência você precisa de uma placa PWM, sem ela vc vai é queimar mais rápido o seu SSR, porque ele vai ficar ligando e desligando em uma frequência muito maior!!!

:rolleyes:
Usa-se SSR exatamente por ele proporcionar acionamentos ilimitados, em frequências baixas e altas (abaixo de MHz).
 

rgaudim

New Member
Afiliado
27/5/17
Mensagens
2
Amigos,

Estou tendo alguns problemas com o uso do Craftbeerpi. Tenho uma placa de interface feita pelo Felipe, todo o sistema funciona a contento nos testes, ontem foi minha segunda brassagem e aconteceu o mesmo que a primeira, que foram travamentos das funções, as vezes os comandos do craftbeer travavam, não aceitando nenhum comando, as vezes, ele continuava ativo, mas deixava de ativar ou desativar a saída do SSR, engraçado que aconteceu sempre durante a mostura, durante a fervura o sistema funcionou normalmente.
Fiz o autotuning e usei os dados para popular o PID boil, ele que esta configurado para controlar o aquecimento.
Na primeira vez, suspeitei de alimentação incorreta, superaquecimento do raspberry. Que foram itens que eu corrigi entre a primeira e segunda brassagem, corrigindo a tensão, adicionando dissipadores e ventoinha. Mas sem resultado.
Imagino que tive que desligar e ligar o sistema umas 20x durante até sair do mashout.

Alguém tem alguma dica? Realmente estou perdido, sem saber se é algo relacionado a Hardware, ou algo do sistema.

Agradeço desde já
 
Afiliado
30/10/19
Mensagens
13
Localização
Jundiaí
Amigos,

Estou tendo alguns problemas com o uso do Craftbeerpi. Tenho uma placa de interface feita pelo Felipe, todo o sistema funciona a contento nos testes, ontem foi minha segunda brassagem e aconteceu o mesmo que a primeira, que foram travamentos das funções, as vezes os comandos do craftbeer travavam, não aceitando nenhum comando, as vezes, ele continuava ativo, mas deixava de ativar ou desativar a saída do SSR, engraçado que aconteceu sempre durante a mostura, durante a fervura o sistema funcionou normalmente.
Fiz o autotuning e usei os dados para popular o PID boil, ele que esta configurado para controlar o aquecimento.
Na primeira vez, suspeitei de alimentação incorreta, superaquecimento do raspberry. Que foram itens que eu corrigi entre a primeira e segunda brassagem, corrigindo a tensão, adicionando dissipadores e ventoinha. Mas sem resultado.
Imagino que tive que desligar e ligar o sistema umas 20x durante até sair do mashout.

Alguém tem alguma dica? Realmente estou perdido, sem saber se é algo relacionado a Hardware, ou algo do sistema.

Agradeço desde já
Salve rgaudim tudo bem, deve ser frustrante ter esse tipo de problema porem se eu pudesse iria eliminando as etapas, a primeira coisa que eu faria, trocar o cartão ssd, após essa etapa ir eliminado as probabilidades, eu no caso não estou usando uma placa de interface eu ligo tudo direto no raspberry usando as entradas gpio veja se encontra o padrão nos tópicos anteriores.

Vai no sistema Craftbeerpi e comece a habilitar item a item, e vai simulando a brassagem.

Boa sorte.
 
Afiliado
4/2/20
Mensagens
1
Localização
SAO PAULO
Bom dia pessoal, lendo este forum me animei de construir meu controlador com o CraftbeerPi. Vou usar um monitor antigo conectado ao HDMI do rasp comprei na china uma tela touch capacitiva para facilitar o uso direto na interface do controlador. A medida que for progredindo aqui vou postando as fotos para a galera que deseja fazer o seu. Sugestões são bem vindas.

Mandei produzir a PCB para interface com o rasp, penso que conectar direto pode ser arriscado. Como o custo na Micropress para fazer uma ou dez placas era o mesmo, fiz dez claro, tenho outras nove sobrando (R$92,00). Se alguem tiver interesse me dá um toque que crio um anuncio no ML. Estimo que os custos totais dos componentes da placa é algo em torno de 50,00 fora os SSRs.

tenho entese na placa
 

Latest posts

Topo