• We have implemented the ability to gift someone a Supporting Membership now! When you access the Upgrade page there is now a 'Gift' button. Once you click that you can enter a username to gift an account Upgrade to. Great way to help support this forum plus give some kudos to anyone who has helped you.

[BrewUNO] Controlador de Brassagem para BIAB, Single Vessel e Tribloco

Ajude o Home Brew Talk Brasil:

P.V.R.F

Member
Afiliado
10/2/19
Mensagens
7
Localização
Santa Maria - RS
Boa tarde pessoal. Estou montando um brewuno sem interface (não achei prazo venda) porém quando eu aciono uma relé o termômetro para de funcionar. Alguém poderia me auxiliar? As vezes ele fica dando erro de leitura e depois volta ao normal, mas quando ligo e desligo a relé de novo, ele dá erro de novo.
 

P.V.R.F

Member
Afiliado
10/2/19
Mensagens
7
Localização
Santa Maria - RS
Mais uma dúvida, é troquei meu módulo relé físico por um de estado sólido com 2 ssr.
Resolveu o problema dia erros de leituras do termômetro, porém eles ficam sempre acionado, têm como eu inverter para eles ficar em desligados, acionarem apenas quando for acionado o relé?
Segue uma foto do modelo.
 

Attachments

José Domingues

New Member
Afiliado
24/12/18
Mensagens
2
Localização
São José do Rio preto
Olá amigos, tenho uma dúvida quanto a eletrônica. Para usar pwm no SSR não é necessário sincronizar com a passagem por zero da rede? Obrigado pela disposição dos colegas.
 

leorjbrz

Member
Afiliado
7/3/17
Mensagens
16
O TRIAC do SSR que faz o controle da curva de disparo, é um chaveamento bem rápido, isso faz com que ele controle a potência que é dissipada pela resistência. Observando o led do SSR vc consegue visualizar quando ele é disparado. Isso vai de acordo com a configuração do PID, como é utilizado no BrewUno.
 

José Domingues

New Member
Afiliado
24/12/18
Mensagens
2
Localização
São José do Rio preto
Se o seu SSR possuir zero-crossing detector sim.
Certo, mas se não tiver, o disparo não vai ocorrer aleatóriamente e causar oscilações no controle da temperatura? Digo pois no diagrama simplificado usando somente o esp8266 não é feita. Hoje utilizo arduino e triac e com estes o zero-crossing é obrigatório. Pretendo mudar para o brewuno mas ainda tenho essa dúvida. Obrigado mais uma vez.
 

leorjbrz

Member
Afiliado
7/3/17
Mensagens
16
Estou com um problema no sensor de temperatura, só lê 85ºC ou 185ºF.

Utilizando a mesma ligação, mesma placa, mesmo sensor, fazendo o upload de um scketch de exemplo do Arduino/DallasTemperature, os exemplos funcionam numa boa, fazem a leitura da temperatura e variação dela.
Já criei um projeto novo pelo platformIo, no loop consigo ler a temperatura normalmente...
Tanto o getTempC quanto o getTempCByIndex retornam sempre 85...

Alguém já passou por isso?
 

Leitao

Active Member
Afiliado
18/2/18
Mensagens
39
Bom dia, Pessoal, gostaria de saber sobre os parametros do PID no BrewUno, onde posso encontrar o que cada parametro significa ou como posso alterar.
bom dia. da uma premiada sobre PID na internet, depois que vc entender vai ficar facil alterar na página de settings. mas sugiro vc nao alterar, e alterar apenas a porcentagem da sua resistencia. o pid do bu funciona bem na maioria dos casos
 

Leitao

Active Member
Afiliado
18/2/18
Mensagens
39
Estou com um problema no sensor de temperatura, só lê 85ºC ou 185ºF.

Utilizando a mesma ligação, mesma placa, mesmo sensor, fazendo o upload de um scketch de exemplo do Arduino/DallasTemperature, os exemplos funcionam numa boa, fazem a leitura da temperatura e variação dela.
Já criei um projeto novo pelo platformIo, no loop consigo ler a temperatura normalmente...
Tanto o getTempC quanto o getTempCByIndex retornam sempre 85...

Alguém já passou por isso?
isso pode ser problema de ligação ou do próprio sensor.
 

Leitao

Active Member
Afiliado
18/2/18
Mensagens
39
Boa tarde pessoal. Estou montando um brewuno sem interface (não achei prazo venda) porém quando eu aciono uma relé o termômetro para de funcionar. Alguém poderia me auxiliar? As vezes ele fica dando erro de leitura e depois volta ao normal, mas quando ligo e desligo a relé de novo, ele dá erro de novo.
possivelmente problema de ligacao ou alimentacao. esta usando uma boa fonte?
 

Leitao

Active Member
Afiliado
18/2/18
Mensagens
39
Olá amigos, tenho uma dúvida quanto a eletrônica. Para usar pwm no SSR não é necessário sincronizar com a passagem por zero da rede? Obrigado pela disposição dos colegas.
dele deveria ser compatível, mas nunca testei no esp32
 

Leitao

Active Member
Afiliado
18/2/18
Mensagens
39
Boa tarde!
Comprei uma placa da Mazza está com o brewmanicaEx queria utilizar o brewuno,
minha duvida oque preciso fazer para rodar de boa o brewuno nela?
precisa verificar se a pinagem é compatível com o bmex/ brewuno. se nao for, precisa recompilar com alteração da pinagem
 

Leitao

Active Member
Afiliado
18/2/18
Mensagens
39
Mais uma dúvida, é troquei meu módulo relé físico por um de estado sólido com 2 ssr.
Resolveu o problema dia erros de leituras do termômetro, porém eles ficam sempre acionado, têm como eu inverter para eles ficar em desligados, acionarem apenas quando for acionado o relé?
Segue uma foto do modelo.
você teria que recompilar. tem um parâmetro no platformio que inverte o ssr
 

Heitor

Active Member
Afiliado
23/1/15
Mensagens
28
Gostaria de tirar uma dúvida em relação ao Brewuno. No meu processo de brassagem utilizo duas panelas e uma bomba. Uma panela para a mostura e outra para fervura. Não faço sparge. É possível com o Brewuno controlar as duas resistências? De acordo com o que eu li e encontrei na internet, o Brewuno controla uma resistência para a água de sparge e outra que é utilizada para a mostura e fervura.
 
Afiliado
27/2/19
Mensagens
23
Localização
Diamantina
Certo, mas se não tiver, o disparo não vai ocorrer aleatóriamente e causar oscilações no controle da temperatura? Digo pois no diagrama simplificado usando somente o esp8266 não é feita. Hoje utilizo arduino e triac e com estes o zero-crossing é obrigatório. Pretendo mudar para o brewuno mas ainda tenho essa dúvida. Obrigado mais uma vez.
Vai ocorrer no instante que o controlador der o pulso em qualquer fase, mas isso não interfere no controle da temperatura. Nossa rede é de 60Hz. Então uma lâmpada liga e desliga 120 vezes em um segundo, mas você não percebe isso pois é muito rápido para nosso cérebro acompanhar. A resistência vai ficar ligando e desligando nessa velocidade quando precisar, mas você ligar a resistência e ela dissipar todo o calor não são duas coisas que ocorrem necessariamente juntas. Quando você liga o fogão com uma panela ela não atingirá a temperatura de fervura instantâneamente, tem uma inércia. O melhor momento para você ligar um equipamento é quando ocorre esse zero, pois a tensão será zero, logo a corrente, mas caso isso não seja possível quem terá impacto é a sua rede elétrica, não o controle de temperatura.

Na figura 2 (anexo) temos sempre o acionamento em zero, mesmo o disparo (barra vermelha ou a bolinha no gráfico) sendo antes. Como temos 4 semiciclos desligados e 9 ligados, temos, na prática, um duty cicle de 9/(9+4)×100%, ie, de 69,23%. De 13 em 13 semiciclos isso se repete. Como a frequência é de 60 Hz, temos 120 semiciclos. Então casa semiciclos tem duração de 1/120 segundos, ie, de 0,0083333 segundos. Então, nesse exemplo, a resistência ficaria 4×(1/120) segundos desligada e 9×(1/120) segundos ligada, ie, 0,0333333 segundos desligada e 0,075 segundos ligada.
 

Attachments

Última edição:

poseidonata

Member
Afiliado
23/4/14
Mensagens
22
Boa noite pessoal, montei o Brewuno com uma placa do Cucanunes, o Dumpa está sem por enquanto, mas estou tendo um problema e gostaria de saber se alguem já teve algo igual, procurei bastante mas não encontrei nada!
Minha resistência é 220v uma fase eu passei pelo rele de estado sólido, liguei a saída da placa da resistência no pino 3 e quatro, quando mexo no pwm a voltagem cai de uma vez (medindo com multimetro) tipo assim 100% da 220v, 98% da 198v, 95% ja da 96v. inicialmente achei que poderia estar desligando o ssr pois estaria mandando menos de 3v que seria o mínimo,mas não é isso, na saída da placa vai gradual de 5v! Alguém já teve esse problema?
 

poseidonata

Member
Afiliado
23/4/14
Mensagens
22
Pessoal respondendo a minha própria questão, depois de pesquisar mais encontrei algo que seria necessário algum equipamento utilizando a energia para funcionar o PWM,não liguei a resistência porque vou trocar o rele tbm já que coloquei um fortek de 25A pra controlar uma resistência de 5000w e pelo que falaram não aguenta, mas testei com uma lâmpada! Quando tem algo ligado ele parece controlar correntemente!
 

fell90

Active Member
Afiliado
26/2/18
Mensagens
32
Terminei de montar o brewuno a algum tempo e só ontem tive tempo de testar pra fim de semana fazer uma breja nele, ontem queria testar o tempo que leva pra chegar nas temperaturas, qual a temperatura de fervura, e como programar basicamente.
Tudo correu bem, só tive um problema na hora de chegar a temperatura de mash, programei 65 pra teste mas aí quando chegava em 64.94 o PWM baixava pra perto de 3% e como ontem tava 16°c a temperatura ficou nessa de baixar e subir o PWM e a temperatura não chegava em 65 ficou uns 2 min pra conseguir.
Domingo vou testar com malte e tudo pra ver como vai ser.
 

Leitao

Active Member
Afiliado
18/2/18
Mensagens
39
Terminei de montar o brewuno a algum tempo e só ontem tive tempo de testar pra fim de semana fazer uma breja nele, ontem queria testar o tempo que leva pra chegar nas temperaturas, qual a temperatura de fervura, e como programar basicamente.
Tudo correu bem, só tive um problema na hora de chegar a temperatura de mash, programei 65 pra teste mas aí quando chegava em 64.94 o PWM baixava pra perto de 3% e como ontem tava 16°c a temperatura ficou nessa de baixar e subir o PWM e a temperatura não chegava em 65 ficou uns 2 min pra conseguir.
Domingo vou testar com malte e tudo pra ver como vai ser.
tenta aumentar pouca coisa o pwm da mostura. qual sua resistencia e volume?
 
2

Latest posts

Topo